Paroles, Accords et Marqueurs

Formatage du texte

Vous pouvez facilement modifier la police, la taille et la couleur du texte de karaoké via le panneau des polices (« Afficher les polices » dans le menu « Présentation > Police »). Le formatage s’applique au texte, aux accords et aux marqueurs. La visibilité des accords et des marqueurs peut être activée/désactivée via les menus « Présentation > Accords » et « Présentation > Marqueurs ».

Taille automatique

Si l’option « Taille automatique » est cochée, QMidi redimensionne le texte en fonction de la hauteur de la fenêtre afin d’afficher un nombre constant de lignes. Les accords peuvent ensuite être redimensionnés indépendamment en faisant glisser le séparateur texte/accords.

Texte enrichi (RTF)

Lors de l’ouverture, tout texte stylé utilisant la même couleur que l’arrière-plan est automatiquement converti en blanc/noir selon la couleur de fond.

Image de fond

Avec le menu « Presentation > Image de fond », vous pouvez ajouter une image d’arrière-plan à votre fenêtre de karaoké. Vous pouvez également glisser une image depuis le Finder.

Vous pouvez aussi lier manuellement une image à un fichier média unique :

  1. Copiez l’image dans le dossier du fichier média.
  2. Renommez-la en utilisant le même nom que le fichier média + l’extension (jpeg, jpg, png, tiff ou tif).

Encodage du texte

Si un fichier karaoké a été créé sur une autre plateforme, les caractères accentués peuvent être incorrects avec l’encodage par défaut. Pour corriger cela, QMidi vous permet de choisir l’encodage texte approprié pour chaque fichier karaoké et de sauvegarder ce réglage dans la bibliothèque/playlist. Vous pouvez modifier l’encodage par défaut dans la fenêtre des Réglages.

Ajout de paroles en mode Édition

  1. Choisissez « Édition » dans le menu « Presentation » (la fenêtre karaoke doit être au premier plan).
  2. Saisissez/collez votre texte.
  3. Sauvegardez via « Fichier > Enregistrer ».

Lors de cette opération, un projet QMidi sera créé dans le même dossier que le fichier média.

NB : Vous ne devez jamais modifier des paroles synchronisées en mode Édition, car cela peut invalider les informations de synchronisation.

Édition en mode Synchronisation

La méthode sûre pour modifier des paroles, accords ou marqueurs existants est la suivante :

  1. Choisissez « Synchronisation » dans le menu « Presentation ».
  2. Cliquez sur les boutons « Paroles », « Accords » ou « Marqueurs » dans la barre inférieure.
  3. Cliquez sur le bouton « crayon » pour activer l’édition manuelle.
  4. Double-cliquez la colonne Texte pour la modifier. Les accords doivent être correctement formatés ! (voir « Format des accords »).

La colonne « CR » sert à ajouter/supprimer des sauts de ligne.

Le comportement du bouton « + » dépend de la sélection :

Ajout d’éléments en mode Synchronisation par collage

  1. Choisissez « Synchronisation » dans le menu « Presentation ».
  2. Collez votre texte. Chaque ligne crée un élément de synchronisation.

Synchronisation

Synchronisation en temps réel

  1. Choisissez « Synchronisation » pour entrer en mode synchronisation.
  2. Cliquez sur le bouton « smiley » pour activer la synchronisation.
  3. Démarrez la lecture. Vous pouvez activer le mode « Tortue » pour jouer à demi-vitesse.
  4. Cliquez la ligne à synchroniser au moment où la tête de lecture atteint la bonne position (touche Retour pour avancer d’une ligne).
  5. Choisissez « Présentation > Afficher » pour sortir du mode Synchronisation.
  6. Sauvegardez via « Fichier > Enregistrer ».

Vous pouvez effectuer l’étape 4 même lorsque la lecture est arrêtée. Il n’est pas nécessaire de tout synchroniser d’un coup : vous pouvez réajuster la position d’une ligne à tout moment. Toutes ces actions sont annulables via « Édition > Annuler ».

Astuces : Option-clic sur une ligne pour déplacer la tête de lecture ; Maj-clic pour déplacer toutes les lignes suivantes.

Édition manuelle de la synchronisation

Entrez en mode Synchronisation et cliquez sur le bouton « Éditer » (crayon) pour activer l’édition manuelle.

La colonne « Position » est au format mesure:temps:tick (pour les fichiers MIDI et médias liés à un fichier MIDI) ou HH:MM:SS.ms.

Menu Action

Séparer/Unir les paroles

Utilisez ces options pour synchroniser mot par mot ou ligne par ligne.

Transformations

Applique la transformation choisie aux lignes sélectionnées.

Décaler

Ouvre la boîte de dialogue de décalage temporel.

Ajuster le tempo

Ouvre la boîte de dialogue d’ajustement du tempo. Vous pouvez allonger ou raccourcir la durée de l’intervalle sélectionné.

Quantiser (MIDI uniquement)

Ouvre la boîte de quantisation.

Recharger

Recharge les données de synchronisation (paroles, accords, marqueurs) présentes dans le fichier média, s’il y en a.

Format des accords

Les accords doivent utiliser le format standard « A#m7/E », où la première lettre est le nom de l’accord (A–G), suivie de l’altération (#, b ou espace), puis de la description de l’accord. Une basse peut être ajoutée après « / ».

Exemples valides :

« B m7 »

« Gbsus4 »

« D#/F » —> basse : F

« E/F# » —> basse : F#